Premier chargement du croquis
Samovar 7.00: au premier démarrage, Samovar 7.00 crée lui-même un profil avec les valeurs par défaut s'il n'existe pas encore de réglages enregistrés. Il n'est pas nécessaire de restaurer manuellement Samovar_default_settings.txt.
Samovar 7.00: l'installation initiale via l'Arduino IDE est prise en charge. L'autre méthode consiste à choisir la carte et les paramètres dans le configurateur, à appuyer sur « Flasher » («Прошить»), puis, pour une carte neuve, séparément sur « Charger LittleFS » («Загрузить LittleFS»).
Lorsque vous installez l'Arduino IDE, le programme crée dans vos documents un nouveau dossier nommé Arduino . Le chemin par défaut est C:\User\Documents\Arduino
Ce dossier doit être préparé.
Lors de son installation, l'Arduino IDE peut placer des sous-dossiers dans ...Documents\Arduino, notamment ceux nommés libraries et tools. Ces dossiers doivent être retirés.
Attention, c'est important !
Pour installer correctement le croquis Samovar, vous devez utiliser les bibliothèques et les outils fournis dans l'archive de chaque version de Samovar. L'utilisation de bibliothèques de versions antérieures ou d'autres sources provoquera une erreur lors du chargement du croquis Samovar dans l'ESP32.
Les recommandations ci-dessous vous aideront à éviter au début les erreurs d'inattention et autres. Par la suite, vous pourrez mettre au point votre propre méthode.
Créez un sous-dossier OLD dans ...Documents\Arduino et faites glisser (ou coupez-collez) les dossiers libraries et tools créés par l'Arduino IDE lors de l'installation dans le dossier OLD .
Si tout est fait correctement, il ne doit plus y avoir de dossiers nommés libraries et tools dans C:\User\Documents\Arduino\. Tout autre nom de dossier est admis.
Téléchargez maintenant l'archive du dernier micrologiciel via ce
lien .
Attention !
Il est recommandé de télécharger l'archive via le lien ci-dessus. C'est une version finalisée et testée . Le dépôt propose aussi une version Master. C'est une future version en cours de développement. Elle peut fonctionner incorrectement, voire pas du tout.
 ZIP
Télécharger l'archive au format ZIP
|
 TAR
Télécharger l'archive au format TAR (RAR, GZ)
|
En règle générale, l'archive est enregistrée dans le dossier "Téléchargements" de votre navigateur.
Nom de l'archive téléchargée : Samovar-X.XX, où X.XX correspond au numéro de version (tous les exemples ci-dessous utilisent la version Samovar-7.00).
Copiez (ou coupez-collez) l'archive téléchargée dans le dossier C:\User\Documents\Arduino\ (votre chemin peut être différent)
-
Décompressez l'archive. Un dossier Samovar-7.00 apparaît.
-
Entrez-y - il contient un autre dossier Samovar-7.00. Renommez-le en Samovar.
-
Déplacez précisément ce dossier Samovar, par glisser-déposer (ou couper - coller) d'un niveau vers le haut, dans C:\User\Documents\Arduino\
-
Entrez dans le dossier Samovar. Il contient des dossiers et des fichiers. Déplacez les deux dossiers libraries et tools par glisser-déposer d'un niveau vers le haut, dans C:\User\Documents\Arduino\
Vous devez obtenir ainsi la structure de dossiers suivante dans ...Documents\Arduino\ :
Le croquis est maintenant prêt à être chargé dans l'ESP32.
-
Branchez l'ESP32 à un port USB.
-
-
Dans l'Arduino IDE, ouvrez le fichier Samovar.ino du dossier ...\Documents\Arduino
\Samovar\.
-
Un clic sur la flèche lance le chargement de la version dans Samovar
Remarque.
-
La compilation du code peut prendre longtemps - ne vous inquiétez pas, soyez patient.
-
Ignorez les lignes surlignées en rouge dans le moniteur de chargement - c'est normal. En cas d'erreur critique, le chargement s'arrête et une barre orange avec le message d'erreur apparaît.
Attention !
Certains clones de la carte ESP32 ne permettent pas de charger le croquis dans l'ESP sans appuyer sur le bouton BOOT.
Il existe deux façons de charger à l'aide du bouton BOOT.
- Si vous maintenez le bouton BOOT enfoncé avant d'alimenter l'ESP, mettez sous tension, gardez le bouton enfoncé 3 secondes puis relâchez-le, vous pouvez flasher l'ESP et tous les réglages effectués auparavant sont conservés. En particulier les réglages de connexion WiFi.
- Si vous mettez directement sous tension et lancez la commande « Téléverser », une fois le croquis compilé et le chargement dans l'ESP32 commencé, la console de l'Arduino IDE, après plusieurs lignes rouges, affiche le message :
"Connecting ....." après quoi des points commencent à apparaître.
À ce moment, appuyez sur le bouton BOOT de la carte ESP32 et relâchez-le lorsque les points cessent d'apparaître.
Appuyer sur BOOT ne fait que mettre la carte en mode chargeur d'amorçage et n'efface pas à lui seul les réglages Wi-Fi.
Installation de l'interface web.
Attention !
À partir de la version 6.0, le système de fichiers utilisé a changé. Le passage à un autre système de fichiers a été fait pour optimiser la vitesse de Samovar.
Une fois le croquis installé, l'interface web doit être installée localement.
Sans débrancher l'ESP32 de l'ordinateur, sélectionnez dans le menu « Outils » :
- ESP32 LittleFS Data Upload - pour les versions 6.0 et supérieures
- ESP32 Sketch Data Upload - pour les versions inférieures à 6.0.
Appuyez de nouveau sur le bouton « Téléverser » de l'Arduino IDE et attendez la fin de l'installation. Sur certaines versions d'ESP32, il faut aussi utiliser le bouton BOOT pour charger l'interface (voir ci-dessus).
Attention ! Important !
Récemment sont apparus des clones de la carte ESP32 qui fonctionnent parfaitement, mais si vous sélectionnez dans le menu « Outils » > Type de carte > ESP32 Arduino>DOIT ESP32 DEVKIT V1, l'interface web ne s'installe pas. Si vous sélectionnez la carte ESP32 Dev Module, l'interface se charge normalement.
Attention ! Important !
À partir de la version 6.0, à condition que Samovar soit connecté à internet, l'interface est automatiquement téléchargée et installée sans votre intervention.
Si vous devez revenir à une version plus ancienne du croquis (pour les versions 6.0 et supérieures), l'interface revient elle aussi d'elle-même à la version correspondante.
En l'absence de connexion à internet, l'interface doit être installée vous-même pour chaque version, c'est-à-dire localement.
Le micrologiciel compare la version de l'interface sur le serveur (web.samovar-tool.ru, le dossier de sa propre version) avec le fichier local version.txt et ne télécharge les fichiers que s'ils diffèrent. Le moniteur série affiche alors les lignes WEB interface version et Local interface version. S'il reste moins de 64 Ko d'espace libre dans LittleFS, la mise à jour est annulée avec le message « Mise à jour de l'interface web annulée : espace disque insuffisant » («Обновление веб-интерфейса отменено: мало места на диске»). Si le système de fichiers n'a pas été monté (carte neuve, flash effacée), le micrologiciel le formate lui-même - message « Impossible de se connecter au système de fichiers, formatage... » («Не удалось подключиться к файловой системе, форматируем...»).
Complément.
Mais, comme il s'est avéré, quelque chose a changé et cela ne fonctionne pas chez tout le monde.
À partir de la version 6.20, un paramètre a été ajouté au fichier Samovar_ini.h :
//#define NOT_USE_INTERFACE_UPDATE //ne pas utiliser la mise à jour de l'interface au démarrage
Lors du premier chargement du croquis, vous devez le décommenter :
#define NOT_USE_INTERFACE_UPDATE //ne pas utiliser la mise à jour de l'interface au démarrage
L'interface ne sera alors pas mise à jour par internet. Elle ne pourra être mise à jour que manuellement. Plus tard, lors du réglage du croquis, vous pourrez remettre la ligne dans son état d'origine (la commenter) et vérifier si la mise à jour par internet fonctionne correctement.
Conseil
Il est recommandé d'effectuer l'installation initiale de l'interface localement, par USB. En effet, si l'option de mise à jour de l'interface par internet est activée, le téléchargement et la mise à jour de l'interface peuvent prendre longtemps. Pendant ce temps, l'interface ne s'affiche pas.
Attention.
Le chargement local de LittleFS est pris en charge dans l'Arduino IDE 1.8.x avec l'outil de chargement classique et dans l'Arduino IDE 2.x avec le plugin ESP32 LittleFS Data Upload.
Complément.
Avec le paquet de cartes ESP32 by Espressif Systems en version 3.0.0 et supérieure, il est devenu possible d'installer l'interface localement avec un plugin pour l'Arduino IDE 2. Les instructions sont ici. Le plugin lui-même (le fichier arduino-littlefs-upload-1.1.7.vsix) se trouve dans l'archive Samovar, dans le dossier tools\ESP32LittleFS_Arduino IDE 2.X : copiez-le dans le dossier ~/.arduinoIDE/plugins/ (sous Windows - C:\Users\<nom>\.arduinoIDE\plugins\), redémarrez l'Arduino IDE, appuyez sur Ctrl+Shift+P et sélectionnez « Upload LittleFS to Pico/ESP8266/ESP32 ».
Remarque.
Sur certaines versions d'ESP32, lors du flashage des versions 6.0 et supérieures avec ESP32 LittleFS Data Upload, l'interface ne s'installe toujours pas. La raison reste un mystère. Si c'est le cas, essayez plusieurs fois, en alternance, de flasher l'ESP32 avec ESP32 LittleFS Data Upload et avec ESP32 Sketch Data Upload. Après chaque flashage, vérifiez si l'interface est apparue.
Une fois le croquis et l'
interface web chargés, redémarrez Samovar en coupant l'alimentation, puis
connectez Samovar à votre réseau Wi-Fi. Une fois Samovar connecté à votre réseau WI-FI, ouvrez l'interface de Samovar sur un ordinateur en saisissant dans la barre d'adresse du navigateur l'adresse IP qui lui a été attribuée, ou le nom http://samovar.local.
Les valeurs par défaut recommandées n'ont pas besoin d'être chargées manuellement.
Samovar 7.00: s'il n'existe pas encore de profil enregistré, le micrologiciel crée et enregistre lui-même les réglages par défaut. Le fichier Samovar_default_settings.txt du dossier tools peut servir à une restauration manuelle, mais il n'est pas nécessaire au premier démarrage.
Pour restaurer manuellement un profil enregistré auparavant, ouvrez « Réglages → Autres » («Настройки → Прочие»), appuyez sur « Charger un fichier de réglages » («Загрузить файл настроек»), sélectionnez le fichier, appuyez sur « Enregistrer » («Сохранить») et redémarrez Samovar. Vous pouvez enregistrer votre propre profil avec le bouton « Télécharger le fichier de réglages » («Скачать файл настроек») du même onglet.
Remarque.
Si le chargement du croquis ou de l'interface de Samovar se passe mal, vous devez effacer la mémoire flash du module ESP32 et recommencer le chargement.