Erstes Hochladen des Sketches
Samovar 7.00: Beim ersten Start legt Samovar 7.00 selbst ein Profil mit Standardwerten an, wenn noch keine gespeicherten Einstellungen vorhanden sind. Eine manuelle Wiederherstellung von Samovar_default_settings.txt ist nicht nötig.
Samovar 7.00: Die Erstinstallation über die Arduino IDE wird unterstützt. Alternativ wählen Sie im Konfigurator die Platine und die Parameter, drücken „Flashen“ («Прошить») und bei einer neuen Platine anschließend separat „LittleFS hochladen“ («Загрузить LittleFS»).
Bei der Installation der Arduino IDE legt das Programm in Ihren Dokumenten ein neues Verzeichnis namens Arduino an. Der Standardpfad ist C:\User\Documents\Arduino
Dieses Verzeichnis muss vorbereitet werden.
Bei der Installation kann die Arduino IDE Unterverzeichnisse in ...Documents\Arduino anlegen, darunter solche mit den Namen libraries und tools. Diese Verzeichnisse müssen entfernt werden.
Achtung, das ist wichtig!
Für eine korrekte Installation des Samovar-Sketches müssen Sie die Bibliotheken und Werkzeuge verwenden, die im Archiv jeder Samovar-Version mitgeliefert werden. Die Verwendung von Bibliotheken aus früheren Versionen oder aus anderen Quellen führt zu einem Fehler beim Hochladen des Samovar-Sketches auf den ESP32.
Die folgenden Empfehlungen helfen Ihnen, anfangs Fehler aus Unachtsamkeit und Ähnlichem zu vermeiden. Später können Sie Ihre eigene Methode entwickeln.
Legen Sie in ...Documents\Arduino ein Unterverzeichnis OLD an und ziehen Sie (oder schneiden Sie aus und fügen Sie ein) die von der Arduino IDE bei der Installation angelegten Verzeichnisse libraries und tools in das Verzeichnis OLD .
Wenn alles richtig gemacht wurde, sollten in C:\User\Documents\Arduino\ keine Verzeichnisse namens libraries und tools vorhanden sein. Beliebige andere Verzeichnisnamen sind zulässig.
Laden Sie nun das Archiv mit der neuesten Firmware herunter, und zwar über diesen
Link .
Achtung!
Es wird empfohlen, das Archiv über den obigen Link herunterzuladen. Das ist eine fertige und getestete Version . Die Quelle enthält außerdem die Master-Version. Das ist eine künftige Version, die sich noch in Entwicklung befindet. Sie funktioniert möglicherweise nicht korrekt oder überhaupt nicht.
 ZIP
Archiv im ZIP-Format herunterladen
|
 TAR
Archiv im TAR-Format herunterladen (RAR, GZ)
|
In der Regel wird das Archiv im Verzeichnis „Downloads“ Ihres Browsers gespeichert.
Der Name des heruntergeladenen Archivs: Samovar-X.XX, wobei X.XX der Versionsnummer entspricht (alle folgenden Beispiele verwenden die Version Samovar-7.00).
Kopieren Sie das heruntergeladene Archiv in das Verzeichnis C:\User\Documents\Arduino\ (oder schneiden Sie es aus und fügen Sie es dort ein; Ihr Pfad kann abweichen)
-
Entpacken Sie das Archiv. Es entsteht ein Verzeichnis Samovar-7.00.
-
Wechseln Sie hinein - dort befindet sich ein weiteres Verzeichnis Samovar-7.00. Benennen Sie es in Samovar um.
-
Verschieben Sie genau dieses Verzeichnis Samovar durch Ziehen (oder Ausschneiden - Einfügen) eine Ebene höher, nach C:\User\Documents\Arduino\
-
Wechseln Sie in das Verzeichnis Samovar. Darin befinden sich Verzeichnisse und Dateien. Verschieben Sie die beiden Verzeichnisse libraries und tools durch Ziehen eine Ebene höher, nach C:\User\Documents\Arduino\
Im Ergebnis sollte in ...Documents\Arduino\ folgende Verzeichnisstruktur entstehen:
Jetzt ist der Sketch bereit zum Hochladen auf den ESP32.
-
Schließen Sie den ESP32 an einen USB-Anschluss an.
-
Starten Sie die
Arduino IDE.
-
Öffnen Sie in der Arduino IDE die Datei Samovar.ino aus dem Verzeichnis ...\Documents\Arduino
\Samovar\.
-
Ein Klick auf den Pfeil startet das Hochladen der Version auf Samovar
Hinweis.
-
Das Kompilieren des Codes kann lange dauern - keine Sorge, haben Sie Geduld.
-
Ignorieren Sie die rot markierten Zeilen im Upload-Monitor - das ist normal. Tritt ein kritischer Fehler auf, bricht das Hochladen ab und es erscheint ein orangefarbener Balken mit der Fehlermeldung.
Achtung!
Bei manchen Klonen der ESP32-Platine lässt sich der Sketch nicht ohne Drücken der Taste BOOT auf den ESP hochladen.
Es gibt zwei Möglichkeiten, mit der Taste BOOT hochzuladen.
- Wenn Sie die Taste BOOT vor dem Einschalten des ESP gedrückt halten, die Stromversorgung anlegen, die Taste noch 3 Sekunden gedrückt halten und dann loslassen, können Sie den ESP flashen , und alle zuvor vorgenommenen Einstellungen bleiben erhalten. Insbesondere die WLAN-Verbindungseinstellungen.
- Wenn Sie sofort die Stromversorgung anlegen und den Befehl „Hochladen“ geben, zeigt die Konsole der Arduino IDE nach dem Kompilieren des Sketches und dem Beginn des Hochladens auf den ESP32 nach einigen roten Zeilen die Meldung:
„Connecting .....“ , danach beginnen Punkte zu erscheinen.
Drücken Sie in diesem Moment die Taste BOOT auf der ESP32-Platine und lassen Sie sie los, wenn keine Punkte mehr erscheinen.
Das Drücken von BOOT versetzt die Platine nur in den Bootloader-Modus und löscht die WLAN-Einstellungen nicht.
Installation der Weboberfläche.
Achtung!
Ab Version 6.0 hat sich das verwendete Dateisystem geändert. Der Wechsel zu einem anderen Dateisystem erfolgte, um die Geschwindigkeit von Samovar zu optimieren.
Nach der Installation des Sketches muss die Weboberfläche lokal installiert werden.
Wählen Sie, ohne den ESP32 vom Computer zu trennen, im Menü „Tools“:
- ESP32 LittleFS Data Upload - für Versionen ab 6.0
- ESP32 Sketch Data Upload - für Versionen unter 6.0.
Drücken Sie erneut die Schaltfläche „Hochladen“ in der Arduino IDE und warten Sie, bis die Installation abgeschlossen ist. Bei manchen ESP32-Versionen müssen Sie auch zum Hochladen der Oberfläche die Taste BOOT verwenden (siehe oben).
Achtung! Wichtig!
In letzter Zeit sind einwandfrei funktionierende Klone der ESP32-Platine aufgetaucht, bei denen jedoch die Weboberfläche nicht installiert wird, wenn Sie im Menü „Tools“ > Board > ESP32 Arduino>DOIT ESP32 DEVKIT V1 wählen. Wählen Sie die Platine ESP32 Dev Module, wird die Oberfläche normal hochgeladen.
Achtung! Wichtig!
Ab Version 6.0 wird die Oberfläche, sofern Samovar mit dem Internet verbunden ist, automatisch und ohne Ihr Zutun heruntergeladen und installiert.
Wenn Sie zu einer älteren Version des Sketches zurückkehren müssen (für Versionen ab 6.0), wechselt auch die Oberfläche von selbst auf die passende Version zurück.
Ohne Internetverbindung muss die Oberfläche für jede Version selbst installiert werden - also lokal.
Die Firmware vergleicht die Version der Oberfläche auf dem Server (web.samovar-tool.ru, Verzeichnis der eigenen Version) mit der lokalen Datei version.txt und lädt Dateien nur herunter, wenn sie sich unterscheiden. Der serielle Monitor gibt dabei die Zeilen WEB interface version und Local interface version aus. Sind in LittleFS weniger als 64 KB frei, wird das Update mit der Meldung „Update der Weboberfläche abgebrochen: zu wenig Speicherplatz“ («Обновление веб-интерфейса отменено: мало места на диске») abgebrochen. Wurde das Dateisystem nicht eingebunden (neue Platine, gelöschter Flash), formatiert die Firmware es selbst - Meldung „Verbindung zum Dateisystem fehlgeschlagen, wird formatiert...“ («Не удалось подключиться к файловой системе, форматируем...»).
Nachtrag.
Wie sich jedoch herausstellte, hat sich etwas geändert, und das funktioniert nicht bei allen.
Ab Version 6.20 wurde der Datei Samovar_ini.h ein Parameter hinzugefügt:
//#define NOT_USE_INTERFACE_UPDATE //das Update der Oberfläche beim Start nicht verwenden
Beim ersten Hochladen des Sketches müssen Sie die Auskommentierung aufheben:
#define NOT_USE_INTERFACE_UPDATE //das Update der Oberfläche beim Start nicht verwenden
Die Oberfläche wird dann nicht über das Internet aktualisiert. Sie lässt sich nur manuell aktualisieren. Später, bei der Einrichtung des Sketches, können Sie die Zeile wieder in ihren ursprünglichen Zustand versetzen (auskommentieren) und prüfen, ob das Update über das Internet korrekt funktioniert.
Tipp
Es wird empfohlen, die Erstinstallation der Oberfläche lokal über USB vorzunehmen. Der Grund: Ist das Update der Oberfläche über das Internet aktiviert, können Herunterladen und Aktualisieren der Oberfläche lange dauern. In dieser Zeit wird die Oberfläche nicht angezeigt.
Achtung.
Das lokale Hochladen von LittleFS wird in der Arduino IDE 1.8.x mit dem klassischen Uploader und in der Arduino IDE 2.x mit dem Plugin ESP32 LittleFS Data Upload unterstützt.
Nachtrag.
Im Platinenpaket ESP32 by Espressif Systems ab Version 3.0.0 ist es möglich geworden, die Oberfläche mit einem Plugin für die Arduino IDE 2 lokal zu installieren. Die Anleitung finden Sie hier. Das Plugin selbst (die Datei arduino-littlefs-upload-1.1.7.vsix) liegt im Samovar-Archiv im Verzeichnis tools\ESP32LittleFS_Arduino IDE 2.X: Kopieren Sie es in das Verzeichnis ~/.arduinoIDE/plugins/ (unter Windows - C:\Users\<name>\.arduinoIDE\plugins\), starten Sie die Arduino IDE neu, drücken Sie Strg+Umschalt+P und wählen Sie „Upload LittleFS to Pico/ESP8266/ESP32“.
Hinweis.
Bei manchen ESP32-Versionen wird die Oberfläche beim Flashen von Versionen ab 6.0 mit ESP32 LittleFS Data Upload trotzdem nicht installiert. Warum das so ist, bleibt ein Rätsel. Versuchen Sie in diesem Fall mehrmals abwechselnd, den ESP32 sowohl mit ESP32 LittleFS Data Upload als auch mit ESP32 Sketch Data Upload zu flashen. Prüfen Sie nach jedem Flashen, ob die Oberfläche erschienen ist.
Nachdem der Sketch und die
Weboberfläche hochgeladen sind, starten Sie Samovar mit getrennter Stromversorgung neu und
verbinden Sie Samovar dann mit Ihrem WLAN-Netz. Ist Samovar mit Ihrem WLAN-Netz verbunden, öffnen Sie die Oberfläche von Samovar auf einem Computer, indem Sie die ihm zugewiesene IP-Adresse oder den Namen http://samovar.local in die Adresszeile des Browsers eingeben.
Die empfohlenen Standardwerte müssen nicht manuell geladen werden.
Samovar 7.00: Gibt es noch kein gespeichertes Profil, legt die Firmware die Standardeinstellungen selbst an und speichert sie. Die Datei Samovar_default_settings.txt aus dem Verzeichnis tools kann zur manuellen Wiederherstellung verwendet werden, ist für den ersten Start aber nicht erforderlich.
Um ein zuvor gespeichertes Profil manuell wiederherzustellen, öffnen Sie „Einstellungen → Sonstige“ («Настройки → Прочие»), drücken Sie „Einstellungsdatei hochladen“ («Загрузить файл настроек»), wählen Sie die Datei, drücken Sie „Speichern“ («Сохранить») und starten Sie Samovar neu. Ihr eigenes Profil können Sie mit der Schaltfläche „Einstellungsdatei herunterladen“ («Скачать файл настроек») auf derselben Registerkarte speichern.
Hinweis.
Wenn das Hochladen des Sketches oder der Samovar-Oberfläche fehlschlägt, müssen Sie den Flash-Speicher des ESP32-Moduls löschen und erneut hochladen.