Samovar 7.00: 下面使用 Arduino IDE 的说明仍然是有效的安装方法。也可以同样使用配置工具:Windows 上用 flash_windows.bat(仅限 64 位 Windows 10/11),macOS/Linux 上用 flash_macos_linux.sh。配置工具会自行安装 PlatformIO 和所需版本的 ESP32 核心,不需要 Arduino IDE。参见
使用 PlatformIO 编译和烧录。无论哪种方式,都需要 USB 控制器驱动(见下文)。
如果您有 ESP32,现在就可以上传草图并测试 Samovar 的工作。
首先,只需把 ESP32 连接到电脑的 USB 端口。
ESP32 开发板带有板载 USB 和 CH340/CH341 或 CP210x 控制器(商品页面上通常会注明)
打开“此电脑 > 属性 > 设备管理器 - 端口 (COM 和 LPT)”(«Этот компьютер > Свойства > Диспетчер устройств - Порты (COM и LPT)»)查看,应该出现一个新端口。
如果电脑检测到了新硬件但没有安装驱动,新端口就不会出现。需要下载您的 ESP32 开发板上控制器的驱动并手动安装。
要把草图上传到 ESP32,需要安装 Arduino IDE。它用作草图编辑器和草图编译器,也用于把编译好的程序上传到 ESP32。。
下面及后续章节介绍一种首次把 Samovar 草图安装到 ESP32 的方法,可以保证成功。
 下载安装程序
用于安装到操作系统中的安装程序
|
 下载 zip 压缩包
无需安装到操作系统即可运行
|
无论 选择哪种方式,网站都会请您感谢开发者,是否感谢由您决定。
如果只想下载程序,点击“JUST DOWNLOAD”按钮。随后会打开另一个窗口,邀请您订阅新闻,再次点击“JUST DOWNLOAD”按钮。
文件会被下载。如果选择的是 zip 压缩包,把它解压到电脑上的任意位置(目录路径中最好不要有西里尔字母)。
如果选择安装程序,建议不要直接装到默认目录,而是在目录名中加上版本号。这样以后使用更方便。
例如。
C:\Program Files(x86)\Arduino1_1_18;
C:\Program Files(x86)\Arduino1_1_16
安装 Arduino IDE 后,需要让它支持 ESP32,默认情况下它不支持。
-
进入解压或安装的文件夹,运行文件 arduino.exe
-
在 Arduino IDE 中打开“首选项”(«Настройки»)窗口。为此,点击“文件” > “首选项”(«Файл» > «Настройки»)。
-
把链接 https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json 粘贴到“附加开发板管理器网址”(«Дополнительные ссылки для менеджера плат»)字段中,如下面的截图所示。
-
注意:
如果该字段中已有其他开发板描述的链接,可以用逗号分隔多个链接。像这样:
https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json, http://arduino.esp8266.com/stable/package_esp8266com_index.json
注意!
如果该字段中有链接 https://dl.espressif.com/dl/package_esp32_index.json,必须删除它。
接下来,在 Arduino IDE 中打开“开发板管理器”(«Менеджер плат»)。
为此,点击“工具” > “开发板” > “开发板管理器…”(«Инструменты» > «Плата» > «Менеджер плат…»)。
打开一个新窗口。在搜索框中输入“esp32”。会找到 ESP32 的扩展包 (或 另一个常用名称:SDK): “ESP32 by Espressif Systems”。
在下拉菜单中选择 2.0.17 版,点击——安装(«Установка») ,等待安装完成
注意:
如果已经安装了扩展包但版本不同,请删除它并安装 2.0.17
PlatformIO 配置工具使用的也正是 2.0.17 版。草图在 3.x 核心下也能编译,但其中 WiFi 更新(USE_UPDATE_OTA)会被自动禁用,而且需要手动把 Samovar 分区表添加到核心中(参见草图更新)。
重启 Arduino IDE,然后在菜单“工具” > “开发板 > ESP32 Arduino”(«Инструменты» > «Плата > ESP32 Arduino»)中选择所需的开发板。
在我们的例子中是“DOIT ESP32 DEVKIT V1”。
检查 “工具 > 端口 > 串口”(«Инструменты > Порт > Последовательные порты»)中选中的是开发板所连接的端口。
现在需要检查一切是否正确。
在 Arduino IDE 中打开示例草图“WiFi Scan”。
为此,点击“文件” > “示例” > (子菜单:DOIT ESP32 DEVKIT V1 的示例)> “WiFi” > “WiFi Scan”(«Файл» > «Примеры» > ... > «WiFi» > «WiFi Scan»),草图会在编辑器窗口中打开。
点击 Arduino IDE 中的“上传”(«Загрузка») 按钮。稍等片刻,代码会被编译并上传到 ESP32 开发板。上传按钮的图标如下:
草图成功上传到 ESP32 后,应该看到消息“上传成功”(«Загрузка завершена»)
在 Arduino IDE 中打开“工具” > “串口监视器”(«Инструменты» > «Монитор порта»),并把波特率设为 115200。
把 ESP32 重新连接到 USB 端口。这样就能在串口监视器中看到 ESP32 开发板周围的所有 Wi-Fi 网络。
ESP32 的设置和检查到此完成。
如果 ESP32 以前用于其他项目,或者 Samovar 草图上传不正常,需要擦除 ESP32 模块的闪存
在 Arduino IDE 中
Arduino IDE 有“Erase Flash”选项。擦除闪存的步骤:
1. 在“工具”→“开发板”菜单(«Инструменты» → «Доска»)中选择合适的 ESP32 开发板。
2. 在“工具”→“端口”菜单中选择正确的 COM 端口。
3. 进入“工具”→“Erase Flash”菜单。在下拉菜单中选择“All Flash Contents”(«Все содержимое флэш-памяти»)。
4. 点击“Erase Flash”选项(«Стереть флэш»)。进度显示在 IDE 底部的输出控制台中。完成后会出现确认消息。
使用 ESPTool
ESPTool 是基于 Python 的开源工具。擦除 ESP32 模块闪存的步骤:
1. 在电脑上打开终端窗口,按住 ESP32 模块上的 BOOT 按钮。
2. 在终端中输入命令,把 COMx 替换为 ESP32 的实际 COM 端口:
python -m esptool --port COMx erase_flash.
3. 按 Enter。
4. 终端中开始擦除后,就可以松开 BOOT 按钮。几秒钟后,ESP32 的闪存会被完全擦除。
使用配置工具
运行 flash_windows.bat(flash_macos_linux.sh),选择开发板的 COM 端口,点击“完全擦除闪存”(«Полностью очистить флеш»)按钮。确认后,固件、LittleFS 和所有已保存的设置都会被删除。该按钮仅在 USB 连接时有效。
重要:如果在消息“Connecting…”之后屏幕上不断出现新的一串点,说明 ESP32 模块没有处于引导/烧录模式。这时请重复上述过程,并在执行时按住 BOOT 按钮