Скачать PDF
        САМОВАР 
×
Меню

Первичная загрузка скетча

Samovar 7.00: при первом запуске Samovar 7.00 сам создаёт профиль со стандартными значениями, если сохранённых настроек ещё нет. Ручное восстановление Samovar_default_settings.txt не обязательно.
Samovar 7.00: первичная установка через Arduino IDE поддерживается. Альтернативный путь — выбрать плату и параметры в конфигураторе, нажать «Прошить», затем для новой платы отдельно «Загрузить LittleFS».
 
Перед первой загрузкой скетча Самовара в ESP32 компьютер и плату нужно подготовить, об этом читайте в "Подготовка ESP32 к загрузке"
 
 
При установке Arduino IDE, программа создаст новый каталог с именем Arduino в ваших документах. Путь по умолчанию C:\User\Documents\Arduino
Этот каталог нужно подготовить.
При установке Arduino IDE может поместить в ...Documents\Arduino вложенные каталоги, в том числе и с именами libraries и tools. Эти каталоги нужно убрать.
 
Внимание, это важно!
Для корректной  установки скетча Самовара нужно использовать  libraries (библиотеки) и tools (инструменты) которые идут в архиве с каждым релизом Самовара. Использование  библиотек прежних релизов или полученных из других источников, будет приводить к ошибке загрузки скетча Самовара в ESP32.
 
Данные далее рекомендации помогут не совершать ошибок на первых порах по невнимательности и пр. В дальнейшем вы сможете выработать свой собственный метод.
 
Создадим в каталоге ...Documents\Arduino вложенный каталог OLD и перетащим (или вырезаем и вставляем)  в каталог OLD  каталоги libraries и tools, созданные Arduino IDE при установке.
Если все сделано правильно, то в каталоге C:\User\Documents\Arduino\ не должно быть каталогов с именами  libraries и tools. Любые другие имена каталогов допускаются.
 
Теперь нужно скачать архив с последней прошивкой по ссылке .

  Внимание!
Рекомендуется скачивать архив именно по выше приведенной ссылке. Это будет законченная и протестированная версия .  На ресурсе так же  присутствует Мастер-версия. Это будущая версия, которая находится в стадии разработки. Она может работать не корректно или вообще не работать.
 
 
Первичная загрузка скетча
1

ZIP

Скачать архив в формате ZIP
2

TAR

Скачать архив в формате TAR (RAR, GZ)
 
Как правило архив сохраняется в каталог "Загрузки" вашего браузера.
Имя скачанного архива:  Samovar-X.XX, где X.XX будет соответствовать номеру версии (далее все примеры будут на версии Samovar-7.00). 
 
Копируем (или вырезаем и вставляем) скачанный архив в каталог C:\User\Documents\Arduino\ (у вас может быть другой путь)
 
Таким образом в ...Documents\Arduino\ должна образоваться следующая структура каталогов:
 
 
 
Теперь скетч готов для загрузки в ESP32.
При нажатии на стрелку начнется загрузка релиза в Самовар
 
Примечание.
 
Внимание!
Некоторые клоны  платы ESP32, не позволяют произвести загрузку скетча на ESP без нажатия кнопки BOOT.
Существует два варианта загрузки с использованием кнопки   BOOT.
- Если перед подачей питания на ESP зажать кнопку BOOT, подать питание, 3 секунды удерживать кнопку, а затем отпустить, можно прошивать ESP  и при этом все сделанные ранее настройки сохранятся. В частности настройки подключения к WiFi.
- Если сразу подать питание и дать команду "Загрузить релиз", после компиляции скетча и старте загрузки в ESP32, в консоли Arduino IDE,  после вывода нескольких красных строк появится сообщение:
"Connecting ....."  после которого начнут появляться точки.
В этот момент нужно нажать кнопку BOOT на плате ESP32, когда вывод точек приостановится, кнопку отпустить.
Нажатие BOOT только переводит плату в режим загрузчика и само по себе не стирает настройки Wi-Fi.
 
 
Установка Web-интерфейса.
Внимание!
С версии 6.0 изменилась используемая файловая система.  Переход на другую файловую систему был сделан для оптимизации скорости работы Самовара.
 
После установки скетча нужно локально установить web-интерфейс.
 
 Не отключая ESP32 от компьютера, в меню “Инструменты” выберите пункт:
- ESP32 LittleFS Data Upload -  для версий 6.0 и выше
- ESP32 Sketch Data Upload -  для версий ниже 6.0.
 
Вновь нажмите в Arduino IDE кнопку "Загрузка", дождитесь окончания установки. На некоторых версиях ESP32, нужно так же использовать кнопку BOOT для загрузки интерфейса (см выше).
 
 
 

Внимание! Важно!
Последнее время появились вполне работоспособные клоны  платы ESP32, но при выборе в  в меню “Инструменты” > Плата > ESP32 Arduino>DOIT ESP32 DEVKIT V1 не устанавливается  web-интерфейс. При выборе платы ESP32 Dev Module загрузка интерфейса проходит нормально.
 
Внимание! Важно!
С версии 6.0 При условии, что Самовар подключен к интернету,  интерфейс будет автоматически скачиваться и устанавливаться без вашего участия.
В случае необходимости отката на старую версию скетча (для версий 6.0 и выше), интерфейс так же откатится на соответствующую версию сам.
Если подключения к интернету нет, то интерфейс необходимо устанавливать, для каждой версии самостоятельно - т.е. локально.
Прошивка сравнивает версию интерфейса на сервере (web.samovar-tool.ru, каталог своей версии) с локальным файлом version.txt и скачивает файлы только при их отличии. В мониторе порта при этом выводятся строки WEB interface version и Local interface version. Если свободного места в LittleFS меньше 64 КБ, обновление отменяется с сообщением «Обновление веб-интерфейса отменено: мало места на диске». Если файловая система не смонтировалась (новая плата, стёртый флеш), прошивка форматирует её сама - сообщение «Не удалось подключиться к файловой системе, форматируем...».
Дополнено.
Но, как выяснилось, что-то изменилось и это работает не для всех.
С версии 6.20 в файл Samovar_ini.h добавлен параметр:
//#define NOT_USE_INTERFACE_UPDATE              //не использовать обновление интерфейса при загрузке
При первой загрузке скетча его нужно  раскомментировать:
#define NOT_USE_INTERFACE_UPDATE              //не использовать обновление интерфейса при загрузке
При этом интерфейс не будет обновляться через интернет. Обновить можно будет только вручную.  В последствии, при настройке скетча строку можно вернуть к первоначальному виду (закомментировать) и посмотреть будет ли обновление через интернет проходить корректно.
 
Совет
Рекомендуется первичную установку интерфейса производить локально, через USB.  Дело в том, что если включена опция обновления интерфейса через интернет, скачивание и обновление интерфейса может занимать продолжительное время. При этом интерфейс не отображается.
 
Внимание.
Локальная загрузка LittleFS поддерживается в Arduino IDE 1.8.x с классическим загрузчиком и в Arduino IDE 2.x с плагином ESP32 LittleFS Data Upload.
Дополнено.
В пакете плат ESP32 by Espressif Systems версии 3.0.0 и выше появилась возможность локальной установки интерфейса с помощью плагина для Arduino IDE 2. Инструкция
здесь. Сам плагин (файл arduino-littlefs-upload-1.1.7.vsix) лежит в архиве Самовара в каталоге tools\ESP32LittleFS_Arduino IDE 2.X: скопируйте его в каталог ~/.arduinoIDE/plugins/ (в Windows — C:\Users\<имя>\.arduinoIDE\plugins\), перезапустите Arduino IDE, нажмите Ctrl+Shift+P и выберите «Upload LittleFS to Pico/ESP8266/ESP32».
 
Примечание.
На некоторых версиях ESP32 при прошивке версий от 6.0 и выше, при использовании  ESP32 LittleFS Data Upload интерфейс все равно не устанавливается. Почему это происходит остается загадкой. Если такая ситуация имеет место попробуйте несколько раз, попеременно,  прошить ESP32 как с использованием ESP32 LittleFS Data Upload  так и с использованием  ESP32 Sketch Data Upload. После каждой прошивки проверяйте появился ли интерфейс.
 

 
После загрузки скетча и web-интерфейса нужно перезагрузить Самовар с отключением питания, а затем  подключить Самовар к вашей Wi-Fi сети.
  Когда Самовар будет подключен к вашей WI-FI сети, откройте на компьютере интерфейс Самовара, введя в адресной строке браузера присвоенный ему IP-адрес или имя http://samovar.local.
 
Рекомендованные значения по умолчанию загружать вручную не нужно.
Samovar 7.00: если сохранённого профиля ещё нет, прошивка сама создаёт и сохраняет стандартные настройки. Файл Samovar_default_settings.txt из каталога tools можно использовать для ручного восстановления, но для первого запуска он не обязателен.
Для ручного восстановления ранее сохранённого профиля откройте «Настройки → Прочие», нажмите «Загрузить файл настроек», выберите файл, нажмите «Сохранить» и перезагрузите Самовар. Свой профиль можно сохранить кнопкой «Скачать файл настроек» на той же вкладке.
Примечание.
Если загрузка скетча  или интерфейса Самовара  происходит не корректно нужно стереть флэш-память модуля ESP32 и выполнить загрузку заново.
 
Первичная настройка Самовара закончена - можно приступать к настройкам файла Samovar_ini.h под собственное оборудование.